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Messaging
Failed to Call Error on All Calls in the Web Client
This article covers the "Failed to Call" error on all calls to or from the web client, usually seen in highly secured environments.
Requirements
For this article to be the correct solution for you, the following must be true:
- The extension is able to open the web client successfully and navigate throughout without issues or errors.
- The extension cannot make or receive any calls via the web client.
- The extension is able to use another device, such as a physical phone or another browser, to make and receive calls without issue.
Cause
This issue is caused by the browser policy option Restrict exposure of local IP address by WebRTC being set to Enabled. This prevents the web client from operating properly and blocks it from subscribing to the WebRTC service used for calling.
This is commonly set as part of the CIS Benchmark for Microsoft Edge (v2.0.0, 1.107, L1), and you must weigh the security risk of potentially exposing your local IP address with the use of the web client.
Solution
Ensure that the policy Restrict exposure of local IP address by WebRTC is set to Disabled. The locations below may differ depending on the browser you're utilizing.
InTune: Settings Catalog > Microsoft Edge > Restrict Exposure of local IP address by WebRTC set to Disabled
Group Policy: Computer Configuration\Policies\Administrative Templates\Microsoft
Edge\Restrict exposure of local IP address by WebRTC set to Disabled
Registry: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Edge:WebRtcLocalhostIpHandling set to REG_SZ value default